Jump to content
Les Forums d'Infoclimat

Ce tchat, hébergé sur une plateforme indépendante d'Infoclimat, est géré et modéré par une équipe autonome, sans lien avec l'Association.
Un compte séparé du site et du forum d'Infoclimat est nécessaire pour s'y connecter.

Davis Weatherlink.com 2.0


Recommended Posts

  • Replies 878
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Oui tout à fait, dans le logiciel Weatherlink, "Set archive interval".       Bon, pour tester un peu le côté pro, l'asso s'est payé un abonnement Pro et j'ai configuré notre plus v

Une MAJ de l’application au top comme d’habitude :    

Je viens de mettre à jour la climato de mars pour la StatIC du Perche, et je crois bien que le bug sur la pluvio lié au système métrique est corrigé par Davis. En tout cas, les 316 mm annuels que je t

Posted Images

Posted
Foussais-Payré (85) / La Bruffière (85)
Il y a 9 heures, gerardt a dit :

Comment tu fais @bianconero pour créer le summary ? 

Maintenant que ça fonctionne, il faut aller sur la page bulletin, puis cliquer sur "Share & Upload" en haut à droite, puis cliquer sur l'onglet "summary" et enfin sur "preview".

  • Merci 3
Link to post
Share on other sites
Posted
Vallée du Lot (46)
Il y a 8 heures, Cyrilleb a dit :

Maintenant que ça fonctionne, il faut aller sur la page bulletin, puis cliquer sur "Share & Upload" en haut à droite, puis cliquer sur l'onglet "summary" et enfin sur "preview".

 

Parfait, merci pour tes explications, cela fonctionne. :) 

Link to post
Share on other sites
Posted
Bannalec (29) - 93 m
Il y a 10 heures, Cyrilleb a dit :

Maintenant que ça fonctionne, il faut aller sur la page bulletin, puis cliquer sur "Share & Upload" en haut à droite, puis cliquer sur l'onglet "summary" et enfin sur "preview".

Merci pour tes explications. 😀

Link to post
Share on other sites
  • 1 month later...

Hello,

 

Je remonte un peu le sujet...

Une connaissance possède une station équipée d'un datalogger USB, il l'a ajoutée sur WeatherLink.com en générant un DID et une clé pour configurer l'update dans le logiciel WeatherLink. Les données sont mises à jour environ toutes les minutes.

 

J'ai fait exactement la même chose.

Cependant, il faut que je laisse WeatherLink démarré sur l'onglet Bulletin (actualisation en live) pour avoir une mise à jour des données.

 

Quelqu'un aurait une idée sur la manière de résoudre ce problème?

 

Merci.

Link to post
Share on other sites
Il y a 3 heures, meteo-melin a dit :

Hello,

 

Je remonte un peu le sujet...

Une connaissance possède une station équipée d'un datalogger USB, il l'a ajoutée sur WeatherLink.com en générant un DID et une clé pour configurer l'update dans le logiciel WeatherLink. Les données sont mises à jour environ toutes les minutes.

 

J'ai fait exactement la même chose.

Cependant, il faut que je laisse WeatherLink démarré sur l'onglet Bulletin (actualisation en live) pour avoir une mise à jour des données.

 

Quelqu'un aurait une idée sur la manière de résoudre ce problème?

 

Merci.

 

Bonjour Clément,

 

Je n'appellerais pas ça "résoudre" mais l'auteur de Virtual VP avait écrit un software qui permet d'ouvrir automatiquement le bulletin.

http://www.softwx.com/downloads.html

Ca s'appelle WLBulletin.  Il n'est plus disponible sur la page ci-dessus mais je l'ai joint à ce message.

 

Je l'utilise personnellement pour garder la page bulletin ouverte.   Je l'exécute toutes les 15 minutes.

Joël

 

 

WLBulletin-1.0.0.zip

Edited by _Joel_
Link to post
Share on other sites

Merci Joël,

 

Malheureusement, il semblerait qu'il y ait un autre problème... 

Avec le bulletin actif et l'upload des différents fichiers générés par les profiles internet ne sont plis mis à jour...

 

Une idée de comment gérer cela?

Link to post
Share on other sites

Salut à tous,
Je viens vers vous car j’ai un petit souci que je n’arrive pas à comprendre…
En fait depuis le début d’après-midi j’ai un problème d’échec de connexion de ma Vantage sur mon site Internet qui s’affiche.
https://xn--mto-yvoy-b1ab.fr/
Je regarde si celle-ci est bien connecté à Internet et pas de problème de ce côté là.
Aucun problème non plus pour faire un Ping sur la station.
Je vais sur le site WeatherLink et là je m’aperçois qu’il y a bien les remontées d’infos mais que je n’ai plus aucun historique de Graph depuis le 22 juillet 🤔
https://www.weatherlink.com/bulletin/2ab6d339-fdae-4cf9-96ef-6f0ed9a92905
Je viens de tester en déconnectant le data log et ensuite en éteignant complètement à la station météo en enlevant les piles pendant quelques minutes mais toujours le même bug…
Est-ce que d’autres sont touchés par le problème ou cela vient de chez moi ?
Merci d’avance pour votre aide😌

8B770927-C953-48F5-A18D-2A9483718E72.jpeg

9D8B3D89-40B3-4912-B7CF-62D0EDC97AD7.jpeg

2356C4C1-2179-42EF-B514-D3C5F5E9DE2C.jpeg

482BF683-355F-4394-86F1-3157207ED2B1.jpeg

E2502F9D-D672-43D8-B88A-9A73FFC2DE29.jpeg

86428635-A117-4997-BB5B-1102DE1B8662.jpeg

Edited by killic
Link to post
Share on other sites

Bonjour @killic,

 

As-tu fait la mise à jour  vers la  V1.1.5 du firmware du datalogger ?

 

En ce qui concerne ton site, les graphiques semblent être à jour, suggérant que weewx arrive bien a récupérer les données depuis le datalogger. C'est la connexion websocket vers ton brokker MQTT qui ne fonctionne pas : WebSocket network error: OSStatus Error -9807: Invalid certificate chain.

Il doit y avoir un problème avec tes certificats  SSL du mqtt

Edited by jackT
Link to post
Share on other sites
il y a 30 minutes, jackT a dit :

Bonjour @killic,

 

As-tu fait la mise à jour  vers la  V1.1.5 du firmware du datalogger ?

 

En ce qui concerne ton site, les graphiques semblent être à jour, suggérant que weewx arrive bien a récupérer les données depuis le datalogger. C'est la connexion websocket vers ton brokker MQTT qui ne fonctionne pas : WebSocket network error: OSStatus Error -9807: Invalid certificate chain.

Il doit y avoir un problème avec tes certificats  SSL du mqtt

Hello, déjà merci pour ta réponse.

Oui j’ai déjà fait la mise à jour du Firmware V.1.1.5 y a quelques temps.

Et oui comme tu le dis les graphismes remonte bien sur mon site mais pas sur WeatherLink🤔

Par contre concernant les erreurs que tu m’expliques j’avoue ne rien comprendre et ne pas savoir comment faire pour la réparer surtout…

Link to post
Share on other sites
il y a une heure, killic a dit :

Hello, déjà merci pour ta réponse.

Oui j’ai déjà fait la mise à jour du Firmware V.1.1.5 y a quelques temps.

Et oui comme tu le dis les graphismes remonte bien sur mon site mais pas sur WeatherLink🤔

Par contre concernant les erreurs que tu m’expliques j’avoue ne rien comprendre et ne pas savoir comment faire pour la réparer surtout…

Bonjour @killic

Pour ma part je pencherais vers un conflit weewx/weatherlink/datalogger le problème est connu, regarde le fil de discussion weewx. Il faut mettre en place une procédure pour laisser le temps au 2 applications de récupérer leurs données. Dans ton cas weewx monopolise la connexion au datalogger et empêche l'envoi vers weatherlink.

Bon courage

  • J'aime 1
Link to post
Share on other sites
il y a 23 minutes, BMGB-59 a dit :

Bonjour @killic

Pour ma part je pencherais vers un conflit weewx/weatherlink/datalogger le problème est connu, regarde le fil de discussion weewx. Il faut mettre en place une procédure pour laisser le temps au 2 applications de récupérer leurs données. Dans ton cas weewx monopolise la connexion au datalogger et empêche l'envoi vers weatherlink.

Bon courage

ha merci pour cette info, je vais chercher pour trouver comment faire 😬

J'envoie mes données sur IC aussi, ca doit pas aider non plus?

https://www.infoclimat.fr/observations-meteo/temps-reel/yvoy-le-marron/000RI.html

Edited by killic
Link to post
Share on other sites
Il y a 2 heures, killic a dit :

ha merci pour cette info, je vais chercher pour trouver comment faire 😬

J'envoie mes données sur IC aussi, ca doit pas aider non plus?

https://www.infoclimat.fr/observations-meteo/temps-reel/yvoy-le-marron/000RI.html

De plus je pense que MQQT ne dois pas arranger car il requête en permanence le datalogger je crois ? Pour les envois sur IC c'est indépendant il récupère les données de la BDD de weewx qui lui a récupéré du datalogger et transmet une fois toute les 10 minutes ce n'est pas la même chose. 😏

Link to post
Share on other sites

Du coup tu me conseilles de faire quoi?

il y a 12 minutes, BMGB-59 a dit :

De plus je pense que MQQT ne dois pas arranger car il requête en permanence le datalogger je crois ? Pour les envois sur IC c'est indépendant il récupère les données de la BDD de weewx qui lui a récupéré du datalogger et transmet une fois toute les 10 minutes ce n'est pas la même chose. 😏

 

Link to post
Share on other sites
il y a 8 minutes, BMGB-59 a dit :

De plus je pense que MQQT ne dois pas arranger car il requête en permanence le datalogger je crois ? 

Même sans MQTT, le driver weewx va systématiquement récupérer les données LOOP toutes les 2.5 secondes. Donc cela ne change rien.

@killic :  si tu utilises weewx 4.1, il n'y a  actuellement, et à ma connaissance, aucun moyen de partager le datalogger IP entre Weewx et weatherlink.com.

Link to post
Share on other sites
il y a 1 minute, jackT a dit :

Même sans MQTT, le driver weewx va systématiquement récupérer les données LOOP toutes les 2.5 secondes. Donc cela ne change rien.

@killic :  si tu utilises weewx 4.1, il n'y a  actuellement, et à ma connaissance, aucun moyen de partager le datalogger IP entre Weewx et weatherlink.com.

Ça devient compliqué pour moi de tout comprendre… Déjà que j’avais eu un mal de chien à tout mettre en place et à comprendre entre guillemets lol

Edited by killic
Link to post
Share on other sites

Bon en arrêtant Weenx, tout mes graph non affiché depuis le 22 juillet son revenu sur WeatherLink...

 

Donc ça confirme un conflit entre les deux...🤨

 

 

 

 

 

Capture d’écran 2020-07-30 à 15.14.59.png

Link to post
Share on other sites
il y a 41 minutes, killic a dit :

Bon en arrêtant Weenx, tout mes graph non affiché depuis le 22 juillet son revenu sur WeatherLink...

 

Donc ça confirme un conflit entre les deux...🤨

 

 

 

 

 

Capture d’écran 2020-07-30 à 15.14.59.png

Regarde mes procédure sous  ta version et  tu auras la réponse topic weewx page 1 premier commentaire tout est expliqué.

  • J'aime 1
Link to post
Share on other sites
il y a 8 minutes, BMGB-59 a dit :

Regarde mes procédure sous  ta version et  tu auras la réponse topic weewx page 1 premier commentaire tout est expliqué.

Cool merci de l’info 😁
tu parle de ton pdf ?

Edited by killic
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...