Jump to content
Les Forums d'Infoclimat

Ce tchat, hébergé sur une plateforme indépendante d'Infoclimat, est géré et modéré par une équipe autonome, sans lien avec l'Association.
Un compte séparé du site et du forum d'Infoclimat est nécessaire pour s'y connecter.

Tétard

WMR200

Recommended Posts

.. bonjour

je suis depuis quelques temps ce forum car je vais recevoir ma WMR 200 d'ici 2 sem je pense

je pense que le fonction de vidage manuel devrait êrtre dans un 1er temps non pas automatique mais avec un bouton supp pour choisir ou non d'activer cette fonction.

c'est juste mon avis qui ne repose que sur vos lectures mais comme il semble que certaines info ou action apparaissent au fur et a mesure le fait de pouvoir activer ou non la fonction permettra a mon sens de deverminer l'action et aisni de cibler le pb.

encore merci a tous de vos participations et j'espere bien pouvoir etre plus pro actif des que j'aurais ma station.

Share this post


Link to post
Share on other sites

Je suis du même avis, pouvoir choisir de vidanger ou non me paraît être une bonne chose, et peut être permettra d'éviter qq soucis...

Share this post


Link to post
Share on other sites

Va pour la coche default_biggrin.png/emoticons/biggrin@2x.png 2x" width="20" height="20"> ! (pour les futures versions ...donc pas tout de suite)

A+

Share this post


Link to post
Share on other sites

Bonjour à tous,

Voila après près de 5000 lignes de programme et quelques (centaines) d'heures de développement, j'ai mis en ligne la version complète du logiciel d'extraction et de décodage de la WMR200.

Toujours au même endroit :

http://site.voila.fr/techmeteo

Version plus souple d'emploi car elle est :

- multi-configurable,

- intègre un logten,

- intègre les réglages de récupération,

- génère un affichage direct...

Évidement et malgré de nombreux tests et vérifications, il est forcément buggé, alors soyez indulgent, et signalez moi les buggs de façon précises : "dans tel cas voici ce qu'il me fait" (avec copie d'écran c'est mieux). Il a été testé sous vista, mais pas sous XP encore moins sous W7.

Merci aux grammeux et ortographeux de me signaler également les "fôtes d'aurtaugrafeux".

Au fur et à mesure des remontées d'informations, je débuggerai tranquillement le logiciel.

Une limitation au logiciel : les niveaux de pile et niveau de réceptions s'ils sont présents ne fonctionnent pas car il reste encore des zones d'ombres dans les données transmises par la console.

PS : tout est en Français.

A bientôt!

Share this post


Link to post
Share on other sites

Re chapeau! Superbe! J'utilise tes logiciels depuis que tu les as proposé, sans problèmes ni bugs, mais là tu transforme littéralement cette console médiocre par son logiciel d'origine. Essaye de le vendre à Oregon qui ne paraît pas capable de faire de même default_biggrin.png/emoticons/biggrin@2x.png 2x" width="20" height="20">

Il ne manque plus qu'un générateur de graphiques et un à la graphweather mais en mieux default_wink.png/emoticons/wink@2x.png 2x" width="20" height="20"> (plus t'en fais plus on en demande default_rolleyes.gif ).

Non ce que que je reproche à GW c'est la "complexité d'utilisation" avec l'obligation de "programmer" (ce qui signifie pour moi "se prendre la tête") genre pour ne pas avoir des graphiques touts petits, ajouter facilement une courbe...

Dans tous les cas encore bravo!

Share this post


Link to post
Share on other sites

Effectivement c'est du très bon boulot!

Je l'ai utilisé pour la première fois avant hier, à première vue pas de bug, et il semble simple à utiliser.

En revanche, j'ai qq questions/suggestions:

Le coef de correction du vent: confirme moi stp qu'il ne sert que si on veut modifier les mesures (hauteur de l'anémo entre autre), régler à 1 il convertit les m/s en kt si on utilise des fichiers compatibles WD? Pour aller plus loin, je pense qu'il serait possible d'en créer un pour les rafales qui serait différent des vitesses moyennes...

Serait il possible de visualiser des kmh (ou autre) au lieu des m/s sur la pages des capteurs?

Je n'est pas d'icône "effacement du logger", contrairement à ce que dit le fichier d'aide, est-ce un volonté de ta part?

Quelle est au juste la différence entre compatibilité WD et compatibilité totale?

Lorsque l'on utilise un fichier compatible WD, confirme moi stp que ce sont bien (par défaut) les précipitations relatives qui sont présentes dans les logs.

Pour l'instant, c'est tout ce que j'ai constaté, le reste est vraiment au top. Grand merci à toi pour le temps passé à développer ce logiciel!!

Share this post


Link to post
Share on other sites

Le coef de correction du vent: confirme moi stp qu'il ne sert que si on veut modifier les mesures (hauteur de l'anémo entre autre), régler à 1 il convertit les m/s en kt si on utilise des fichiers compatibles WD? Pour aller plus loin, je pense qu'il serait possible d'en créer un pour les rafales qui serait différent des vitesses moyennes...

Le coëfficient de correction est un coëfficient multiplicateur. Il doit être à 1 pour ne pas faire de correction. Quant à sa valeur elle est à la convenance de l'utilisateur. Quelques explications dans l'aide.Lorsque l'on est en "compatibilité WD" quoiqu'on mette en facteur de correction le résultat enregistré dans le fichier pour le vent est en kt. Ceci dit j'ai laissé une décimale, on ne perd alors plus de précision.

Bien sûr que l'on peut créer un coefficient différent pour les rafales et le vent moyen, mais ça commence à compliquer l'utilisation pour le "lambda moyen". Je crois qu'il faut surtout travailler à implanter le capteur de vent à des endroits ou le flux de vent est dit laminaire, c'est à dire très haut, et pas sur un toit surtout. Maintenant c'est sûr que tout le monde n'as pas un champ à sa disposition!

Serait il possible de visualiser des kmh (ou autre) au lieu des m/s sur la pages des capteurs?

Oui en rentrant la bonne valeur du coëfficient de correction qui ne sera alors plus un coëfficient de correction, mais un coëfficient de transcriptions d'unité. (ceci dit le commentaire m/s restera affiché)

Je n'est pas d'icône "effacement du logger", contrairement à ce que dit le fichier d'aide, est-ce un volonté de ta part?

C'est pas normal, Par contre il est à droite complètement du bandeau d'infos de fichiers, peut être qu'il est "planqué" à cause de ta config écran.Sur le site techmeteo tu as le visuel, et tu peux repérer sa position (en haut complètement à droite). Il est volontairement éloigné des autres boutons pour éviter une fausse manip. L'effacement est aussi disponible dans le menu.

Quelle est au juste la différence entre compatibilité WD et compatibilité totale?

La compatibilité totale c'est le fichier WD "classique" et l'autre c'est le classique plus toutes les mesures qui sont pas dans le classique.Quelques explications dans l'aide "configuration"

Lorsque l'on utilise un fichier compatible WD, confirme moi stp que ce sont bien (par défaut) les précipitations relatives qui sont présentes dans les logs.

Tout à fait contrairement au décodeur ancienne version, ou la pluie n'était pas bien formatée "WD". Sur W200_V3 c'est bien la pluie relative qui est enregistrée (j'ai passé un moment à programmer la pluie pffff! wacko.gif ).Pour toutes les unités enregistrées, dans la config il y a une coche "inclure l'entête des fichiers" si elle est cochée, toutes le unités sont expliquées dans le fichier enregistré (à ne faire qu'une fois pour voir)

Pour les décodages de fichier on peut les faire les uns à la suite des autres, ils se mettent alors bout à bout et l'on enregistre tout d'un seul coup.

Share this post


Link to post
Share on other sites

Ok faberb et merci de ces précisions...

Je retiens donc le coef de correction du vent pour l'affichage dans la fenêtre, l'icône planquée (je dois avouer que j'avais pas pensé à ça).

J'ai eu un petit plantage hier:

La configuration que j'avais rentrée alors de la première utilisation semble n'avoir pas été enregistrée (malgré la validation). Du coup le logiciel se trouvait en vitesse max (ce qui fait planter ma connexion), je vérifierai à la prochaine extraction si le souci se renouvelle.

Share this post


Link to post
Share on other sites

Bonjour à tous,

je viens d'installer et de tester pour la première le fameux logiciel de Faberb. Bravo pour le visuel et pour la vitesse d'extraction, car actuellement avec WD ceci prend un temps incroyable.

J'aurai cependant quelques petites questions. Après avoir vérifié ma config écran, je n'ai pas l'icône "effacement du Datalogger", j'ai vérifié avec le visuel sur le site tecmeteo, mon écran est strictement identique avec ce visuel, il me manque juste l'icône (j'ai bien regardé en haut à droite...).

J'ai fait un premier test d'extraction et mon datalogger est vidangé suite à cette opération. Est-ce normal ?

Merci d'avance pour les réponses et encore bravo pour le fa

Share this post


Link to post
Share on other sites
Posted

Location : Lestrem(62)

Slt

Oui en effet le logiciel est bien !

Mais par contre j'ai des petits pb

Pourquoi il y a 2 cases a cocher "assurer une compatibilité avec WD " ?

c'est quoi la différence ?

Sinon Graphweather me dit que les correspondances dates /colonnes est incorrect

Share this post


Link to post
Share on other sites

bonsoir

nouvel utilisateur de l'extracteur j'en remercie l'auteur faberb.

je le decouvre avec ma nouvelle WMR 200.

n'utilisant pas WD je ne coche pas compatibilité avec WD mais lorsque je lance la transformation en fichier texte je retrouve 2 fois JJ MM AAAA (1 pour la date acteuelle et 1 pour an 2000) malgre avoir vider le datalogger

si faberb ou quelqu'un dautre a une explication je suis preneur et encore merci à vous tous

Share this post


Link to post
Share on other sites

S'il s'agit du premier transfert, c'est peut être tout simplement la date qu'il y avait avant que la station ne soit mise à l'heure (réglage initial de date et heure). Supprime la ou les lignes concernant 2000 et je pense que tout rentrera dans l'odre par la suite.

Pour faberb,

je te confirme moi aussi, ne pas avoir d'icône pour l'effacement du data logger,

J'ai de plus tenté d'utiliser le coef de correction du vent, ça marche effectivement pour l'affichage, mais dans mes logs aussi (compatibles WD), le vent était donc multiplié deux fois... Je sais pas s'il s'agit d'un bug ou si j'ai simplement mal interprété ton dernier message à ce sujet. Dans le doute...

bonne soirée!

Share this post


Link to post
Share on other sites

je reviens avec ce sujet sur mon entete de log

-----------------------

date_JJ MM AAAA HH mm pluie_relative Taux/h 1h 24h Cumul... Date_JJ MM AAAA HH mm Dir_vent Inconnu_2 Rafales Moyenne T°_ressentie UV Pression_Relative Pression_Absolue Prévisions Tend_T°int T°int Tend_Hum_int Hum_int P_rosée_int Indice_chaleur_int Nbre_capt_ext Tend_T°_1_ext T°_1_ext Tend_Hum_1_ext Hum_1_ext P_rosée_1_ext I_chaleur_1_ext

-----------------------------------

comme vous le voyez je me trouve avec dans l'entete 2 fois date JJ MM AAAA et cette fois ce n'est plus plus 2000 mais 2007 j'avais vide le data logger et je retrouve de nouveau dans les données et aussi dans l'entete 2 fois JJ MM AA comment se fait il que l'extracteur fasse apparaitre 2 fois JJ MM AAAA peut etre faberb peut il me répondre dans l'attente d'accès a son forum GW

cordialement

Share this post


Link to post
Share on other sites

la deuxième date est tout simplement le date du dernier reset du cumul de pluie.. c'est 2007 car quand la station s'allume, la date par défaut avant de se mettre à l'heure par radio est celle-là.

Share this post


Link to post
Share on other sites

Super Faberb, tu vas peut-être maintenant savoir résoudre mon problème pour que je puisse basculer sur ton soft:

J'utilise Graphweather depuis un bon moment et je coince avec ma nouvelle config.

Jusqu'à présent, j'utilisais xnetmeteo et donc j'uploadais mes stats sur mon site sans aucun soucis en utilisant le plugin csv. Depuis aujourd'hui, j'utilise ta dernière version, j'ai donc paramétré mes colonnes en utilisant le plugin csv optionnel 1 pour continuer mes stats mensuelles et annuelles avec l'intégralité des données de l'ancien soft et du nouveau. Et c'est là que ça coince, soit j'ai les anciennes, soit les nouvelles, car en optionnel 1 il faut refondre les templates en ajoutant "_1" à chaque capteur donc impossible d'avoir toutes les données sur la même feuille de stats.

As-tu une astuce? Dommage qu'il faille mettre ce satané "_1" sinon tout serait ok. Je pensais aussi refaire tous les tableaux csv et les rendre identiques aux tiens mais beaucoup trop de boulot pour les dates.

A part ça ta nouvelle mouture fonctionne parfaitement. Juste une idée, lorsqu'on a que deux capteurs, la possibilité de virer tous les autres de l'affichage principal et de remonter le vent et le pluvio au même niveau que les 2 capteurs pour éviter les scroll surtout sur un mini pc en 1024x600 :-)

++

Share this post


Link to post
Share on other sites

il me semble pourtant que j'avais vide le data logger alors pour la deuxième date je comprends mal cette date de 2007, néanmoins il me suffira de choisir les bonnes colonnes dans le plug in csv de GW

une autre question sur GW comment visualiser les temp et humid interieures. quelle est la bonne feuille de style?

d'avance merci

Share this post


Link to post
Share on other sites

Je me répète la deuxième date n'a aucune importance, je ne vois pas pourquoi vous butez la dessus. Et cela n'a rien avoir avec le datalogger et n'est ni un bug!

la deuxième date est tout simplement le date du dernier reset du cumul de pluie.. c'est 2007 car quand la station s'allume, la date par défaut avant de se mettre à l'heure par radio est celle-là.

et pour hum et temp intérieure il faut mettre indoor_temp et _hum dans data d'une feuille

Share this post


Link to post
Share on other sites

ok pour la feuille quel logiciel utilisé pour modifier une feuille de style xml. j'ai entendu parler d'editeur wysiwyg est ce cela.

merci

Je me répète la deuxième date n'a aucune importance, je ne vois pas pourquoi vous butez la dessus. Et cela n'a rien avoir avec le datalogger et n'est ni un bug!

la deuxième date est tout simplement le date du dernier reset du cumul de pluie.. c'est 2007 car quand la station s'allume, la date par défaut avant de se mettre à l'heure par radio est celle-là.

et pour hum et temp intérieure il faut mettre indoor_temp et _hum dans data d'une feuille

Share this post


Link to post
Share on other sites

Bonjour à tous,

J'utilise W200 V3 depuis sa sortie, et ça fonctionne très bien, tout comme les premières versions du logiciel. Toutefois, il ne permet pas réellement de faire du temps réel, tout du moins de créer un log tout en décodant les trames (comme le faisait WD). J'ai cru comprendre que Xnet le permettait (d'ailleurs pertmet il d'extraire les données du datalogger?), je souhaiterais donc en savoir un peu plus sur ce logiciel.

Mon objectif est de l'associer à GW, j'aimerais donc savoir s'il génère un log en .txt (seul format que j'arrive à comprendre pour l'instant...). J'aimerais également que qq utilisateurs me permettent de voir comment le logiciel se présente (copie d'écran ou site). En clair, je recherche toutes informations pour choisir au mieux le logiciel que j'utiliserai au jour le jour.

Share this post


Link to post
Share on other sites

ok pour la feuille quel logiciel utilisé pour modifier une feuille de style xml. j'ai entendu parler d'editeur wysiwyg est ce cela.

merci

moi j'utilise bonfire studio et il est très bien.

xnet fait bien du temps réel, mais le pblm, c'est qu'il ne fait justement pas de txt. Les logs sont en excel.

Share this post


Link to post
Share on other sites

sur le site de xnet il est explique comment utiliser graphweather avec xnet, d'ailleurs ne pouvant pas le tester de suite , je suis surpris de mettre une extension csv dans les fichiers de données

Share this post


Link to post
Share on other sites

C'est bon, j'ai testé Xnet. Je suis assez satisfait du résultat, et il permet effectivement de visualiser en temps réel sous GW. La prise en main est super simple, le plugin fait même tous les réglages de GW. Je verrai bien à l'usage celui des 2 logiciels que j'utiliserai, sachant qu'ils ont chacun leurs avantages, mais GW ne permettra pas de passer de l'un à l'autre facilement, notamment car les réglages sont différents.

Autre chose qui n'a absolument rien à voir, mon datalogger ne dispose plus que de 19 jours, pb que j'ai déjà rencontré mais que je pensais avoir réglé en supprimant définitivement une autre sonde OS fonctionnant avec une autre sation. Dans mon entourage je ne vois aucune autre station météo, je ne comprends donc pas pourquoi ce pb est revenu... Si qq'un a un élément de réponse...

Share this post


Link to post
Share on other sites

merci de cet ^petit test de xnet si j'ai le temps ce WE je ferais de meme

j'avais prévu de rajouter 3 capteurs vu la diminution conséquente de taille mémoire je ne sais si je vais continuer dans cette voie

C'est bon, j'ai testé Xnet. Je suis assez satisfait du résultat, et il permet effectivement de visualiser en temps réel sous GW. La prise en main est super simple, le plugin fait même tous les réglages de GW. Je verrai bien à l'usage celui des 2 logiciels que j'utiliserai, sachant qu'ils ont chacun leurs avantages, mais GW ne permettra pas de passer de l'un à l'autre facilement, notamment car les réglages sont différents.

Autre chose qui n'a absolument rien à voir, mon datalogger ne dispose plus que de 19 jours, pb que j'ai déjà rencontré mais que je pensais avoir réglé en supprimant définitivement une autre sonde OS fonctionnant avec une autre sation. Dans mon entourage je ne vois aucune autre station météo, je ne comprends donc pas pourquoi ce pb est revenu... Si qq'un a un élément de réponse...

Share this post


Link to post
Share on other sites

bonjour tout le monde,

à tous les utilisateurs Mac

j'ai une station WMR200 depuis quelques temps, mais, utilisateur Mac

jusqu'aujourd'hui, j'utilise Weather Display pour Mac, et n'ai aucun problème pour lire les données relevées par la station, ce qui est le but je crois !, mais j'arrive en fin de période d'essai de WD (70$), et par contre, pour interpréter, voir mettre en ligne sur un site ces données, je n'ai trouve aucun équivalent Weather Display Live ou GraphWeather

sur Mac, j'ai aussi la possibilité de faire tourner Windows à l'aide d'un soft de virtualisation, et dans ce cas, utiliser Weather Display et, soit Weather Display Live ou GraphWeather, et dans ce cas, Windows (84€) et éventuellement WDL (40$)

donc, avant d'acheter n'importe quelle licence, à vous, Macusers, quelle solution avez-vous adopté, peut-être des softs Mac que je n'ai pas trouvé, pour peut-être pouvoir utiliser iWeb afin de mettre en ligne (vous aurez compris qu'il ne faut pas me demander grand chose en informatique)

je suis preneur de toute solution éventuelle

merci à vous

Davy

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...